Jump to content

Final Fantasy from the beginning (Currently @ FFXII)

Recommended Posts

Down in the Waterway, we meet a woman named Amalia, who claims to be part of the Resistance and is looking for her comrades. She joins the team as a guest, which means I can give her commands/gambits, but she doesn't have a license board.


With a fourth member in the group, the enemies get tougher and we come up against a miniboss, a group of slimes (sorry, flans... wrong franchise!) with high resistance to physical attacks, but Fran's fire magic does good damage. Cue the victory fanfare when we win! :)


Further along, we encounter a tougher boss, a flaming horse called Firemane. Unfortunately, I don't have any water or cold magicks, so I have to resort to attacking it and healing a lot. With gambits, you always want healing as first priority in the stack, above any attacks, otherwise your allies won't heal while there are still enemies in the field. Fortunately, it looks like you can amend gambits even while you're in battle, so if you've set up fire spells and suddenly come up against an unexpected fire horse, you don't accidentally screw yourself over.


Still, I would like a lot more conditions unlocked before I can fully rely on automation. When I'm fighting manually, I'm often thinking about resource management (only use item if >X in stock), remaining MP (stop using spells when X% remains), distance from save points (prioritise spells if near somewhere you can rest), etc. I don't know if gambits can cover all of those variables eventually but right now they don't.


Vaan and the others are surrounded by imperial soldiers after the horse fight, and they throw us in Nalbina dungeon. (Nalbina is where the game began and the king was killed). Vaan has a dream about his dead brother in some sort of strangely bright hospital, pleads with him to tell him what happened on that mission with Basch, but of course he's not real and he disappears, and then Vaan wakes up in a dark dungeon. It's an underground lair beneath the old palace where the empire throws people to die. Bodies lie around the place and the survivors have no hope of escape. All of our equipment is gone so we have to fight a trio of bullies with our fists, after which a Bangaa bounter hunter is escorted into the dungeon by imperial guards, looking for Balthier, followed by someone known as a Judge, who I am sure we will meet properly later. The bounty hunter sounds Scottish and most the Imperials sound English (as does Balthier - maybe he's a defector!). For now, we manage to slip out through an exit Fran has discovered and collect our equipment from a room.


We fight our way through more of the dungeon (stealth? Pah!) and I begin to wonder why these two sky pirates are following a kid around... until I realise that you can set anyone you like as the party leader. You can switch Vaan off entirely if you like!


We follow that Judge from earlier into a room with a caged Basch, looking disheveled and worse for wear. The plot, it seems, thickens...

Link to comment
Share on other sites

19 minutes ago, Sprite Machine said:

With gambits, you always want healing as first priority in the stack, above any attacks, otherwise your allies won't heal while there are still enemies in the field.


I still forget this. And then I think that my healers are daft for running towards certain death. However, by the end of the game "attack nearest foe" is buried below all of the status ailment and HP threshold conditions, as it should be. :P 

Link to comment
Share on other sites

The Judge removes his helmet and he looks like Basch. So... Basch wasn't the one who killed the king, it was a setup by his... identical twin? Vaan still doesn't trust him but once the Judge has left, we release the real Basch from his cage and drop down to the levels below. A lone trader down here sells a bunch of scavenged stuff and I purchase new equipment and top up on every Gambit I can get.


Basch joins the team as a 'guest' and we explore the Barheim passage, which consists of old railway tunnels and electricity-eating creatures called Mimics. We have to stop them from draining energy conduits so that the lights stay on and we can open the powered gates. At the end, there's a Queen Mimic boss, but this is fairly easy.


Fran keeps mentioning something called 'Mist' that she can sense. I don't know what it is, but if it's anything like the Mist from FFIX, it's not good news. Maybe something that spawns monsters?


We exit Barheim passage and emerge in the Estersand, the desert to the east of Rabanastre. This is very familiar, I definitely remember this part of the game.


One very handy new feature in this version is the speed up time function. If you're confident in your Gambits, or in an area with low level monsters, you can set it to 2x or 4x speed and just rip through everything. Although I don't know what it says about the game that it can be improved by speeding through it... :unsure:


Back in Rabanastre, Basch and the others leave and Vaan is told to lie low. I pick up two new hunting marks to try later, and purchase a load of Gambit conditions from the shop, selling most of my dropped loot and trinkets to pay for them (I don't need that stuff for anything else, right?). There's some good ones in there but I will have to buy more when I have more gil. I also briefly visit the hunting clan hideout.


I believe Balthier and Fran are hiding in the bar...

Link to comment
Share on other sites

In Lowtown, I visit Dalan again and show him the Magicite stone I stole from the palace. Impressed, he gives me an old sword to take to a secret Resistance meeting in the upper town. Inside, Basch is arguing with another man (Vossler, I think? I struggle with names and the subtitles aren't headered!). The Resistance group is not fully trusting of Basch and his story - even if true, he's still brother to an Imperial Judge - but Vaan finally trusts him. We leave, Basch takes the sword and rejoins my party, this time as a full character rather than a guest. I select the Knight license board for him, as that seems like a good fit.


Basch says he needs 'wings', so he wants to see Balthier. I head back to the bar and find Migelo confronting Balthier and Fran. Apparently, Penelo has been kidnapped and Migelo blames Balthier for it. With a bit of convincing, we all agree to take the airship and rescue her.


So now I have four full characters from which to choose a party of three. Decisions, decisions! First of all, I need some more stuff and I have no more cash, and there's two hunts to go on. Perhaps I'll do those first (and leave poor Penelo 'til later).

There are two marks nearby, a Wraith and a Flowering Cactoid. Neither proves too challenging, although the Cactoid knocks out Vaan with his 1000 Needles attack, and Wraith casts Doom on everybody but I finish the fight before the timer hits zero. Interestingly, status effects remain even after fights, at least until you can cure them or find a save point.


Getting around Rabanastre is made easier now thanks to the Moogling, a teleport network controlled by Moogles, who in this game look more bunny-ish than ever.


I go to the Aerodrome to meet Balthier and finally get underway. We're heading to the Lhusu Mines in Bhujerba, a Magicite mining city on the sky continent of Dorstonis, ruled over by Marquis Ondore and generally left alone by the Empire. So... a floating island? (Airships are said to be powered by sky stones, so that would follow.)


We board Balthier's airship, the Strahl. Like much of the technology in this world, the Strahl has a steampunk style to it that I find appealing. Balthier and Fran sit in the cockpit like Han and Chewie, click mechanical buttons and the Strahl blasts off out of the Aerodrome towards Dorstonis in a lovely prerendered FMV sequence.


I haven't commented much on the presentation and graphics in FFXII. Obviously the FMVs are always great in Squaresoft games, but FFXII is generally good looking in all respects. Coming from FFX, which had nice looking art but bad animation, FFXII has improved the character animation considerably, using what looks like mo-capped cutscenes, and makes use of better cinematography, depth of field effects and stylish framing. Vocal performances are also much improved, and the storytelling is full of intrigue and complexity. On the Switch (at least in handheld), the game is quite 'soft' looking, which is either an intentional anti-aliasing effect or it's struggling to hit native res, but it looks really nice so I'm inclined towards the former.


Penelo is trapped in a dungeon as bait by some Bangaa. When we arrive in the politically neutral Sky city of Bhujerba, the Aerodrome is locked down and Imperial soldiers are everywhere, seemingly looking for someone. Outside the Aerodrome, we meet a kid named Lamont who is also trying to get to the mines. Lamont joins the party as a guest and is a white magic user with a lot of Gambit slots!


Bhujerba is indeed a floating city, held in the sky by Magicite and Moogle technology. Its people have some unfamiliar words in their language that gives them an exotic vibe. Most of the routes through Bhujerba are blocked by Imperials, except one that leads to the mines.


Coming up on 9 hours now and I'm not bored yet.

Link to comment
Share on other sites

I go into the Lhusu mines looking for Penelo, but instead find... a plot? Lamont is looking for evidence somebody creating artificial 'Nethicite', an anti-magic material, in the mines. The Marquis is possibly helping the Empire but possibly plotting against it, I'm not really sure what's going on. Lamont is actually Larsa, the younger brother of Lord Vayne. Meanwhile, the bounty hunters looking for Balthier attack us in the magicite cave and we have to run all the way out of the mines again. Using the 'flee' command keeps everyone from automatically attacking, but I'm still hit occasionally by either the hunters or the monsters, so I have to stop and let Fran cure us, it's quite a pain. Penelo has already been set free by the hunters and Larsa finds her on the way out and takes her to safety back at Ondore's estate. I don't know what his deal is, honestly.

Once back to safety, Vaan and the others try to get some information by shouting that Captain Basch is alive, which gets the attention of some freedom fighters and I end up in a bar called the Cloudborne, whereupon I find a bill for another mark and gladly accept it. I'll push the story on shortly but I should try to take on the 'Nidhogg' first. Once I'm done here, I need to go to the Marquis' estate in the north of the town.

Back in the mines, the Nidhogg awaits. It's a large floating serpent, and it's incredibly fast. I almost defeat it but it seems to go into a rapid attack 'rage mode' towards the end and I can't take the hits. Fortunately, the game has an auto-save feature I didn't know existed, so I pop back in the same room rather than go all the way back to the save crystal. Like most dungeons, the mines are repetitive and dull, but if I want to be strong enough to beat the Nidhogg, I'm going to need to level up or at least earn more gil to upgrade my equipment.

I do my first bit of 'grinding' in the mines, which is actually quite tolerable when you can increase the speed and let your characters do their own thing. The explosives hidden in the floors are annoying, though (heh, mines in the mine). After a few trips, I have enough to purchase new weapons and equipment. This is sufficient to defeat the Nidhogg, although it is still a bastard of a thing. Even when its life bar looks depleted, it still attacks like crazy. I use up some Hi-Potions and Phoenix Downs but eventually it falls and I return to the bounty poster for my reward.

The need to unlock licenses to use equipment and spells (in additional to buying or finding them) is a little bit annoying. I know it's done so that only certain jobs can use each thing and I'm sure I'll get used to it, but... mnyeh.

I return to the Lhusu mines one last time to check if I missed anything. There are several blocked routes, suggesting I will have to come back here another time. Something else I've noticed, that makes this feel less like a traditional Final Fantasy and more like an MMORPG, is that all of the item boxes / capsules in dungeons respawn, dropping random loot or arbitrary amounts of gil each time. I've nothing against that, it's just a bit unusual.

To push to the story on, I go to Marquis Ondore's estate. Vaan wants to see Penelo but she's already left. Basch wants Ondore's help to rescue Amalia from the Empire, however Ondore wants to keep Basch captive. When we resist, we're captured and handed over to Judge Ghis and taken aboard the Dreadnought Leviathan, a large air ship of sorts. Perhaps that was part of the plan, though, because Amalia is there on the Dreadnought too. In a sudden twist, she reveals herself to be Princess Ashe, who I thought died by suicide in the game's opening, but apparently not. The Goddess Magicite that Vaan is holding begins to glow and the Judge takes it and sends us all to our cells.

I'm glad I spent a bit of time in the mines now; the game doesn't like to hang around any one place for long!

Link to comment
Share on other sites

3 minutes ago, Sprite Machine said:

Fortunately, the game has an auto-save feature I didn't know existed, so I pop back in the same room rather than go all the way back to the save crystal.


Added in Zodiac, and genuinely great (when it works in your favour.) It allows for more risk-taking without that fear of losing a bunch of progress.

Link to comment
Share on other sites

Before we're taken to the cells, we're broken free by Vossler, who was disguised as a Judge. He joins us as a guest character and we run through the corridors of the Dreadnought Leviathan, fighting imperial guards and a couple of minor Judges, before breaking Princess Ashe from a detainment cell. At this point, the game has gone full Star Wars: Ashe is Leia, Ondore is Lando, Bhujerba is Cloud City! :D

Ashe joins as a full character so I can assign her a job. The twelve jobs are quite flexible with some crossover in abilities, and I understand these were new in the Zodiac version? I make Ashe a 'Bushi' (swordmaster), which basically means she'll get more sword weapon licenses as the board unlocks but also gets other abilities. The job type is more like a specialisation.

We escape the cells and head towards the docking bay, when we meet up with Larsa and Penelo. Larsa seems to be on our side after all and Penelo gives Vaan the piece of Nethicite that they took from the mines. (I equip this - it halves elemental damage while inflicting silence.)

Judge Ghis tries to stop us at the docking bay, but we fight and defeat him thanks to some new Mist / Quickening abilities that I've just unlocked (special unique abilities, like Limit Breaks?). I don't quite understand these yet, ie. how often they can be used, what their limitations are, etc. More research needed.

We escape in a little shuttle and return to Bhujerba. Marquis Ondore wants Princess Ashe to stay there but she wants to reclaim her throne and kick Lord Vayne out. Trouble is, she can't prove her birthright without the Dawn Shard, so Balthier concocts a plan to 'kidnap' the Princess and take her to the Tomb of Raithwall. I love Balthier and Fran, they're such cool characters. 8-)

Meanwhile, in Arcadia, the Emperor is ill/dying and contemplating his successor. He talks to Gabranth about his loyalty to the empire and his brother Basch, and about Larsa and Vayne, but I don't quite catch what he asks him to do.

The Strahl hovers and parks above the Westersands (further out west from Rabanastre than I've previously ventured) and we have to go the rest of the way on foot - something about skystones not working there. However, the merchant in the desert had loads of good stuff, including level 2 spells, which I can't afford - so I instead head back in the direction of Rabanastre to collect some monster loot in the desert to sell. I'm in no rush.


Is there any use for this stuff - wolf pelts, stones, feathers and the like? I've just been flogging them, I hope I don't need them for anything later... :unsure:


Link to comment
Share on other sites

11 hours ago, Sprite Machine said:

Is there any use for this stuff - wolf pelts, stones, feathers and the like? I've just been flogging them, I hope I don't need them for anything later... 


From what I remember there’s a crafting system in this game that they never tell you about. By flogging various combinations of materials at a store, you’ll unlock new items to purchase through the “bazaar” submenu of a store. I rarely did this so I might be missing certain details, but that’s the gist.


Also, whilst a lot of it’s for selling, you need to be careful as certain items classified as “loot” have their uses, such as teleport stones. So you can’t just mash the sell button on everything.

Link to comment
Share on other sites

11 hours ago, Sprite Machine said:

Before we're taken to the cells, we're broken free by Vossler, who was disguised as a Judge. He joins us as a guest character and we run through the corridors of the Dreadnought Leviathan, fighting imperial guards and a couple of minor Judges, before breaking Princess Ashe from a detainment cell. At this point, the game has gone full Star Wars: Ashe is Leia, Ondore is Lando, Bhujerba is Cloud City! :D

Loved this bit of the game. It's great for grinding, you can get huge combos just wandering the corridors for ages, then when you're ready head for the boss. 

Link to comment
Share on other sites

The Westersands gets the occasional sandstorm but it doesn't impede my monster hunting. Once again, the 2x speed mode is invaluable for this sort of thing. Soon, I have enough gil to purchase new spells but I'm still short on cash to get a full set of new armour for now. Never mind, time to move on.

Further west is the Ogir-Yensa Sandsea, a vast stretch of desert that looks like a rippling ocean (of sand). Upon it are large abandoned oil rig drilling platforms. I remember these, so I know I definitely got this far in the game before. We are soon attacked by the Urutan Yensa, a strange-looking cloaked people (basically Sand People!), who we fight across the bridges and platforms of the oil rigs. Yossler appears out of nowhere, having followed us, and joins as a guest character.

The area west of this is yet another vast desert called the Nam-Yensa Sandsea, and here we accept a request to beat a large tortoise-like beast called the Urutan Eater (high defence, looks like an Adamantoise).

Yossler can do special attacks called Wither and Expose, which lower attack and defense strength respectively. Applying these to Gambits is tricky, though. If I put Expose in the stack, telling it to target high defence enemies, he will continually use Expose and never move to the next Gambit. What I need is conditional logic, to only target an enemy once, or to stop if the move has already been used, or when defense reaches a certain level. I don't feel I have enough flexibility yet, which is kind of annoying because Gambits have the potential to be so much fun with a little more depth.

Link to comment
Share on other sites

Man, reading my old forum posts from 2006 is fascinating (and slightly confusing - the old smilies are muddled up)!

I was really digging the game for a good few hours and then you can see how it gradually wore me down. It seems like I was significantly lower level than I am now and struggling a lot with bosses. The fact that I'm finding the game quite a bit easier to handle now could either be because I've levelled up more or because the game balance and features have changed more than I thought in the Zodiac version. It certainly sounds like the license boards were simpler in the original version, but less specialised? Did characters even have specific job types before, I can't recall?


The outside of King Raithwall's Tomb is guarded by a fiery bird called Garuda. This is a boss fight in which I can't rely fully on Gambits, since short range weapons can't reach high enough to hit him, and I stick with manual inputs for the most part. Nevertheless, it's not too difficult a fight, and beating it clears the way to the Tomb. Ashe explains who the ancient King was and what the shards were for, then we enter the tomb through a teleport terminal.

The inside of Raithwall's Tomb has a single long path raised above a large dark room. Immediately upon stepping onto the path, a large statue in the wall behind us comes to life and starts sliding slowly towards us. I am able to run away from the Demon Wall, all the way along the path and to the next room (the same but mirrored), but then another one approaches from the other side, so I decide to fight it. Using advice from my 15 year younger self in the other thread, I use a Reflectga Mote to stop Demon Wall's magic attacks (temporarily changing my Cure gambits to Potions, etc.), and I manage to defeat Demon Wall on my first try. Fran is sent into the 'X-Zone', which is a sort of vanished status, but she reappears when I move to the next room. Weird!

The rest of the tomb contains dead-ish things like Liches, Zombies and... spiky giant head things. It's very dark in here, to the point that I can barely see treasure chests a few feet in front of me. It doesn't help that everything is textured various murky shades of brown, a common theme for this game.

Raithwall's Tomb is quite large, winding and symmetrical. Through a hidden corridor, I reach what I assume is the centre. A room full of dense Mist contains a boss, Belias the Gigas, a fire creature. I had thankfully removed my recent 'Oil' status, which would otherwise have left me very vulnerable to its attacks. I unleash all the 'Quickening' attacks I have, which I still don't understand. I can chain them together by pressing a button during the attack animations and I end up doing about 10000HP damage, which is very handy.

When beaten, I discover Belias is an 'Esper'. In other words, this becomes my first Summon! Belias was the guardian of King Raithwall's tomb.

In the room where the Dawn Shard is kept, Ashe sees the ghost of her husband Rasler and promises to avenge him. On leaving the tomb, an Imperial fleet led by Judge Ghis drops down from the sky and captures us. Vossler did a deal with the Empire, to give Ghis the Dawn Shard in exchange for Lady Ashe taking back her throne. Ghis takes the Dawn Shard, which he tells us is actually something called deifacted nethicite, and sends the rest of us to another airship called the Shiva.

While testing the nethicite, it overpowers Ghis's ship's systems. Fran goes berserk, as if feeling the Mist around her overheating. Then we escape in the confusion, fighting Vossler (another boss!) and escaping the fleet as the entire thing explodes. The Mist manifests itself into fiery creatures and the whole 8th Imperial fleet is destroyed. As the fire fades, we fly back and pick up the Dawn Shard hovering in the debris.

The Empire has taken a very big hit. Nevertheless, with the risk of retaliation present, Ashe decides not to reveal herself as alive yet, even though she's spent the last however long wanting to do just that. Marquis Ondore narrates this bit of the story, as he did the prologue. I guess this is an "End of Disc 1" sort of moment? :D

Link to comment
Share on other sites

After the loss of their biggest fleet, the Arcadian Council convenes a meeting. The senate blames Lord Vayne and suggests the Emperor must discipline him in some way. They also favour his brother Larsa for the throne.

Meanwhile, the rebels have regrouped at Rabanastre and are planning their next move. They think it likely the Empire already has or will have the two other 'Shards' / Nethicite pieces, and Ashe wants to use their piece as a weapon against the Empire. Trouble is, no-one knows how to use it. Jahara, village of the Garif people, lies to the south, past the Giza Plains, and they apparently know how to use these ancient stones, so that's the next destination. Balthier requests payment for his services in the form of Ashe's ring. Vaan, on the other hand, doesn't seem to have any motivation - he's just there because he's inexplicably the main character.

I'm not going to head south until I've done some more training. I accept three more hunts at the bar (two of which I can't do from here), then head out west to level up my lower characters (Penelo, Basch and Balthier) as well as grab some loot and raise license points. The Esper I received has been added to the licence board, though only one character can learn to summon it. Additionally, I can now access a second license board, and therefore second job, for each character. This certainly makes things more interesting. I'm thinking Fran should do some achery, and let's give Balthier some black magic.

Fighting the same enemies on the oil rigs to the west racks up some epic chains and drops better loot. I have to say, whatever my misgivings about the Gambit system, it doesn't half make grinding less of a chore! You can pretty much turn your brain off and tear through enemies at double speed, occasionally checking your status or MP.

The Wyvern Lord, the first of my marks, is further to the west. I defeat it without too much difficulty, then return to Rabanastre for my reward. I have enough gil to purchase the Hunter's Monograph, which is an item that improves loot drops. Once I'm satisfied I've done enough here, I head south to the Giza Plain, where it is now heavily raining. There's a lightning elemental here that would quickly kill me if I didn't run away.

Beyond Giza Plain is Ozmone Plain, where I encounter new enemies, including wild chocobos, which I feel a bit bad about fighting. Beyond here is Jahara, the land of the Garif, non-'hume' warrior people with horned masks. I meet a Garif War-chief outside the village, who lets me in so I can speak to the elders about Nethicite. However, before I do that, one of the Garif has another mark for me to hunt, back on the Ozmone Plain...

Link to comment
Share on other sites

There are actually two marks available, Enkelados, a big stone monster in Ozmone Plain, and Croakadile, a giant toad in Giza Plain (and not a Pokémon like it sounds). I don't have much difficulty with either, as I think I'm a higher level than I need to be.

Giza Plain is very different in the rainy season. It's marshy, all the paths are thinner and the monsters are different. I don't understand what triggered the change or if it will return to how it was.

With the hunts done, I return to Jahara to meet the elder chief, who unfortunately isn't able to help us. He says the Nethicite has been used, the power it had stored for many years expelled in the blast that destroyed the imperial fleet.

Fortunately, Larsa takes this opportunity to track us down in the village (he gets around) and implores Ashe to take her place on Dalmasca's throne and broker a peace with Archadia, which she isn't sure she wants to do, but is persuaded that it will avoid a bloody war. Vaan and Ashe have a heart to heart and the next morning, we set off by chocobo towards somewhere called Mt. Bur-Omisace in eastern Kerwon.

Travelling by chocobo stops any enemies from attacking you, so it's quicker to get where you're going. I won't do it often; it's usually beneficial to fight en route. Larsa is now in the party as a guest (again!).

After a cutscene where imperial Judges talk about their plans, I'm back with the team and we go east into Golmore Jungle, though like most areas in this game, it's more of a series of corridors. Here I fight Malboros, Gargoyles, Panthers and other creatures. Malboros are really small, and not quite as annoying as they are in earlier games, though they still inflict status effects.

Several routes through the jungle are blocked by energy barriers, so Fran uses some sort of spell to open a path to Eruyt Village, where we hope to meet her people, the viera. (I assume they will all have bunny ears like her.) The moogles we rescued from the Leviathan are selling stuff by the entrance, including spells, although what I really need are more Gambit conditions.

I don't remember any of this part of the game, the jungle or the village. My playtime clock tells me I've hit 23 hours, so I've passed my previous time, and looking back at my old forum posts, I think I've just passed the point where I gave up in 2006 - I mentioned that one of the recent marks was too tough, and my highest level was 20. Now my highest level is 33! Purely out of interest, I thought I would load up my old PS2 save on an emulator and compare, but unfortunately I don't seem to have that save file any more.

Link to comment
Share on other sites

I've realised what bothers me about the license system. If I'm at a shop, I will often overlook weapons, armour and magic that I can't use yet. Similarly, when I'm moving around the license board, I'll often overlook licenses for weapons, armour and magic that I haven't bought yet. So I end up either not getting anything or having to check between two places to see what I need. It's annoying!

Eruyt Village is like a Playboy Bunny convention. The viera are all women with rabbit-like ears and skimpy outfits. They're an isolationist people who do not look fondly on Fran's decision to leave the woods 50 years earlier (Vaan gets some stick for asking her how old she is). We're looking for someone named Myrn, possibly a relation to Fran, but she isn't here. Jote, who also appears to be important in the village, tells Fran that Myrn has left and headed west. We deduce that she has gone to the Henne Mines, south of Ozmone Plain.

Once out of the jungle, I come across some injured imperial soldiers, who I assist in return for a chocobo ride. There are parts of the map only accessible by chocobo, where tracks go through thick grass that you can't cross on foot. I find the entrance to the Henne Mines, but there are several bodies outside. Larsa says they are researchers from Draklor laboratory, wherever that is. Is the Empire doing some shady shit here?

The mines are not a welcome sight, comprising yet more corridors and darkness, this time with a system of alternating red and blue doors hindering my path. A group of ambushing blue flans temporarily tests my resolve, but otherwise I don't find the monsters much trouble. In a cave full of Magicite, we find more bodies, and see Myrn acting strangely, as if affected by the Mist. She runs off and we pursue.

In the next room, we're attacked by a big-ass dragon called Tiamat. I like the boss music, it's exciting! Tiamat doesn't prove too difficult; I get him stuck in a cycle of him casting reflect on himself and dispelling him, which allows me to whittle away his health with physical attacks. Once beaten, Myrn is releasesd from her trance. She had been exposed to some manufactured Necithice that sent her into a rage, much like what happened to Fran earlier on the airship. Myrn is Fran's sister - and, apparently, so is Jote. Back in the village, Jote gives us a charm called Lente's Tear that will open the barriers in the forest for us to pass. Myrn wants to leave the village but Fran tells her to stay. Fran has lost the ability to hear the voice of the Wood due to being away from it for so long, and doesn't want that to happen to her sisters.

After a quick trip to Bhujerba (via warp crystal) to stock up on a bunch of gambits I didn't have, I go back to Golmore Jungle and head down the now unblocked paths. To the east, I come out into an opening where I'm attacked by... yet another boss!

The Elder Wyrm is a big, green, moss-covered dragon, and this fight is tougher than the last. Even the boss music is different but I don't know what this thing is or why it's important. I feel a bit bad fighting it, it seems like I just woke it up. This fight takes longer, requires healing various status effects but, promisingly, my gambits take care of the bulk of it, which is very satisfying. Towards the end, I switch in Ashe (you can swap characters mid-fight) and use her to summon Belias. Summons in FFXII work differently from previous games - they become temporary characters, fighting alongside the summoner, and can be given commands. 'Hellfire' finishes the Elder Wyrm off nicely.

I gotta say, I'm rather enjoying the game at the moment. I have a few minor gripes about various systems, but on the whole it's a fun and different take on Final Fantasy.

Link to comment
Share on other sites

When I last played it I made sure to buy all the majiks once they appeared in the shops then I only had to unlock them on the board. 

If you see either the bubble magic or bubble belts anywhere deffo get them. You will

not be disappointed. 

Link to comment
Share on other sites

13 hours ago, Sprite Machine said:

Eruyt Village

Bunny girls aside, it has one of my favourite BGMs in the game, and a great town/village theme generally. It’s just got this gorgeous chill vibe and has the feel of a classic FF location tune :wub: 



Link to comment
Share on other sites

In Archadia, Vayne speaks to his father Gramis of vague rebellion against the Senate, claiming blood is already on his hands. Nobody talks in a straightforward fashion, so I don't know what they're planning, but it's all very Shakespearean. Meanwhile, Balthier tells Larsa not to trust the Empire at their word of peace. Nevertheless, we continue to Mt. Bur-Omisace, through the snow-covered Paramina Rift. There are various snowy varieties of the same enemies I've fought elsewhere.

The town at the top is a neutral holy land, untroubled by empires and war, that welcomes pilgrims and refugees alike, protected by the Kiltias people. We are here to see the Gran Kiltias Anastasis in a massive palace built into the mountain. This is where we will broker a peace agreement. He is a 'Dreamsage', which means he can see the future or see into people's thoughts or something. He appears as a very wrinkly old man who talks to us through his mind.

Joining us in our meeting is an eccentric young gentleman named Al-Cid Margrace, representing the kingdom of Rozarria. This chap sounds somewhat Italian, or whatever Ivalice equivalent of Italy is. Although he is sympathetic to Larsa and Ashe's call for peace, he informs everyone that Emperor Gramis is dead and that Vayne has taken over control of Archadia, citing emergency autocratic powers.

With Vayne ruling the Empire, the chances of peace are gone. Larsa leaves the party to stay with the Gran Kiltias, while Ashe is told she needs to find the Sword of Kings in the Stilshrine of Miriam (who comes up with these names, honestly?). So, yet again, a plot thread has gone nowhere and now I have to go back through the Paramina Rift to find another important trinket that will probably turn out to do nothing.

I purchase a map to the Rift to help me find the way through. Once I arrive in the Stilshrine area, I find a few articles with ice protection attributes. I could be wrong, but I'm guessing some sort of ice monster is coming...

Link to comment
Share on other sites

I'm slightly concerned that three characters are under-levelled, as they don't appear to receive any EXP when they're not in the party, so to that end I temporarily put Basch back in the team. Penelo is only level 20 because I barely use her, oh well.

The Stilshrine of Miriam is visually similar to Raithwall's Tomb, dark and stony, being another vault of the ancient king. The theme here is 'statues'. Statues and heads of statues come to life and attack, while other statues need to be rotated to open a final colossal statue that seals the main vault. The Dawn Shard needs to be equipped to activate most of these things, otherwise zombies attack. And one of the enemies is disguised as a save crystal, the fiend!

A couple of bosses reside here: Vinuskar the manufactured dragon, and Mateus the Corrupt, another Esper. As expected, this is an ice-based boss and looks a bit like Shiva (although upon reading the bestiary, it's a bit weirder than that).


I summon Belias to help out at the end. Summons are weird, they appear as a support character and continue walking around with the summoner even after the battle, casting cure or whatever. You have to manually dismiss them. Or I suppose they could be killed, I don't know. I will need to decide who to give Mateus to, as only one character can be assigned each Esper.

From the vault, we retrieve the Sword of Kings, a blade capable of destroying Nethicite. Ashe sees the ghost of Rasler again and we leave. The sword can actually be equipped as a two-handed weapon by anyone, as it doesn't need a license! Its stats aren't anything special, however I give it to Balthier.

Upon leaving the Stilshrine, a huge fleet of Imperial ships flies overhead and I get a serious case of déjà vu! It doesn't land and keeps going, but leaves a plume of smoke rising from Mt. Bur-Omisace. Surely the Empire wouldn't attack a neutral holy land, would it? I run back through the Paramina Rift to find out...

Current playtime: approaching 30 hours
Highest level: 39 (Vaan)

Link to comment
Share on other sites

On 05/03/2022 at 14:05, Sprite Machine said:

I'm slightly concerned that three characters are under-levelled, as they don't appear to receive any EXP when they're not in the party, so to that end I temporarily put Basch back in the team. Penelo is only level 20 because I barely use her, oh well.

For most of the game you can stick with a core team - however, the one thing that caught me out was not having a levelled-up white mage outside of my main party. Later on it can get tricky if your main healer/support dies and nobody can step in.

Link to comment
Share on other sites

The might of the Archadian military, led by Judge Bergan, has left Bur-Omisace in ruins, and the Gran Kiltias dead. While Larsa fled with Gabranth, Judge Bergan is still here, shrouded by a veil of Mist, caused by the man-made Nethicite he carries, and he wants a fight.


I'm probably overlevelled, because unleashing all my Mist/Quickenings kills Judge Bergan immediately! Al-Cid Margrace, enters, wounded, to tell us that Larsa is safe. Ashe wants to take the Sword of Kings to destroy the Dusk Shard but doesn't know where it is. Balthier suggests the Empire has it in Draklor laboratories, deep in the heart of Archadia. The people of Bur-Omisace, meanwhile, will have to rebuild.


So the next destination is Archadia, north of Rabanastre, through Nalbina. However, this is the perfect time to put the main quest on hold and go and do some more hunts. Visiting the pub in town, I discover 7 new marks and accept them all. The first is a White Mousse (flan) in the Waterways under the town. I haven't been down here in a while and the monsters seem to have gotten tougher. Amusingly, there are some Malboro Overkings with crowns and moustaches! I find and defeat the White Mousse but not without using up a lot of status healing items, which I will need to replenish.


The next mark is Marilith, a serpent type creature in the Zertinan Caverns. This is very similar to the one I fought in the mines earlier, in as much as - when nearly dead - it goes into what I can only describe as 'turbo-bastard' mode, speeds up its turns and whacks every character for over a thousand damage per hit. This gets me stuck in a loop of reviving and dying (all handled automatically by gambits), which would be amusing if it wasn't also annoying. Eventually, it defeats me and I decide to try an easier mark instead (Marilith is Rank V, most others are Rank III).


There's a Rank II mark called Ixtab in the Henne Mines, and Feral Retriever (giant Coeurl) in the Paramina Rift, neither present too much trouble, although the latter does kill me once.


Vorpal Bunny is running around Golmore Jungle, and I have to chase him down and hit him with ranged attacks and Quickenings. The Ring Wyrm, who looks like a variant of Tiamat (with the floating metal collar around its neck), is in the Dalmasca Westersand during its sandstorm phase. This one proves quite challenging but is still only Rank III.


I can't accept any new marks until I reach Nalbina, so I'll either go there next or try to defeat Marilith again.

Link to comment
Share on other sites

22 hours ago, Sprite Machine said:

I can't accept any new marks until I reach Nalbina, so I'll either go there next or try to defeat Marilith again.


Clearly I'm a glutton for punishment, as I decide to take on Marilith again. This time, I wait until he goes into berserk mode before unleashing my Mist attacks, and this does the job. Returning to Rabanastre, I discover there are another four hunts available! Blimey, well, some of them are higher rank still, so perhaps they can wait.


Side note: quickening and summon animations are excellent, particularly the main attack of Mateus, who swims through the water and turns it into a pillar of ice, before shattering it to pieces!


I head north via the Estersands until I reach South Bank Village. There's a boat that crosses the river but it isn't running right now, so I head back a different way and come across Nalbina Town, which has a fortress (and an introductory FMV sequence). Based on the low level spells and equipment for sale here, I gather I could have visited much earlier! I meet a couple of the new hunt bill posters but there's nothing else to do here so I move further north, into a mountainous region called the Mosphoran Highwaste.

From here, I can go back down through another part of the Estersands and reach the North Bank Village, the other side of the boat crossing, except the village is mysteriously empty aside from a Moogle cartographer.


It's worth travelling around, filling the map and seeing where the exits lead. It makes navigating easier, as this world is interconnected and quite complex, despite being essentially a series of wide corridors.


I easily defeat the Rank III mark Atomos en route through Mosphoran Highwaste again, this time continuing north and crossing a bridge over to the Salikawood. This is very peaceful forest with relaxing background music and it's putting me to sleep, so I'm going to end it there for the week!

Link to comment
Share on other sites

In the Salikawood, I have to find several worker Moogles scattered around and get them to finish building a gate to access the next area, Phon Coast.

Phon Coast is on the Empire's doorstep, so I'm getting close now. Balthier chats to Ashe about his past and reveals that he used to be a Judge! His father, Doctor Cid of Draklor Laboratories, became obsessed with nethicite and lost his way. Balthier ran away to become a sky pirate, but fate has put him on the path of nethicite again so now he wants to stop running. Ashe reminisces about Rasler.

Cid has been cropping up in 'Meanwhile, in Archadia' cutscenes here and there but I guess we're finally going to meet him.

Phon Coast has a Hunter's Camp with a few hunters scattered around. (A hunter gathering, you might say!) They tell me the Tchita Uplands are ahead of here but powerful fiends are roaming around Sochen Cave, which I believe is the underground route I need to take into Archades, as we can't enter the city by air.

A child gives me a crudely drawn bill for a mark in Sochen Cave (not a real bill, it doesn't appear in the Clan Primer) and a Soul Ward key for getting in there. The key opens the door to an abandoned palace inside the cave.

Well, mostly abandoned. A quintet of speedy onions (Mandragoras) ambush us, but I manage to beat them. Further through the old tomb, fighting zombies and headless ogres, I encounter another boss, Ahriman, a floating evil spirit. This thing makes illusory copies of itself towards the end of the fight, which is almost enough to be mildly challenging, but not quite. *shrug*

I often feel like I'm not so much 'playing' FFXII as I am 'vaguely directing some characters around as they play the game for me'. Point them towards a group of enemies, turn the speed up, watch them win. Move on, repeat, level up occasionally. Satisfying in a way, but oddly detached.

An old mechanical lift at the end of the tunnels takes us up into Archades. Well, Old Archades - this is their 'Low Town', a slum for the poor on the outskirts. Across a bridge is the proper capital, the Imperial City of Archades itself, full of giant buildings glimmering like a modern metropolis. After paying for some helpful advice from a man named Jules and distracting some guards, I sneak into the city and mingle with the wealthy locals. Balthier goes off to run an errand while I visit the shops.

To get into the posher parts the city, I need to take a taxi, but the driver asks for 'Chops', whatever they are. Jules will tell me, for a fee. Unfortunately, I've just spent all my gil in the shops so I can't pay him. A quick trip back down into the cave palace to get some loot, and I've got enough. (Maggoty flesh is very valuable, who knew?) There are a couple of suspiciously locked doors down in the cave that suggest a return at a later point.

To earn 'chops', it seems I must talk to people around the city and do favours for them, by memorising their problems and using them as solutions to other people's problems. Networking that will set me up the social ladder, or something.

Link to comment
Share on other sites

So, chops are wooden ornaments that denote status. You get given them for doing good deeds. Conveniently, each district of the city has precisely the right number of people with problems and solutions, so this is basically a matching pairs game. Listen to somebody's problem and then find the person who can help. A frustrated architect wants a commission, a talented magick user needs a tutor, an aspiring boutiquer needs a wealthy investor, and so on. I actually only need three chops to access the sky taxi, but I get a bit carried away with my altruism and end up with twenty-eight! The basic chops are pinewood but they can be traded for a sandalwood chop, which earns even higher respect.


Balthier rejoins us and we take a ride to Draklor labs, going in through the service entrance. The place is quiet and many dead soldiers are lying around. Research staff have locked themselves into rooms and I have to open red and blue doors to make my way through the maze of corridors, which is a bit tedious. I go up to floor 70 to find Cid, although he is already accosted by a sky pirate named Reddas.


A strange fight ensues. Cid is just a bespectacled man but he surrounds himself with mechanical drones and some sort of magical field. After the fight, Cid calls it 'Venat' and it appears to be the same Mist creature that infects those holding nethicite. Cid escapes in an airship before we can finish him, taking the stone with him. He's heading for somewhere called Giruvegan... some sort of holy land?


At this point there is another narrated break in which Ondore explains the Imperial Senate was dissolved and war is inevitable. A resistance fleet led by Ondore is then seen flying through the air. I can't help but feel events are not being affected in any way by anything I do. What was the point of going to the laboratory again?


Now I'm somewhere called Balfonheim Port, a harbour town way to the east on the map. Reddas and his sky pirates are going to help me get to Giruvegan, which is through the Feywood in Golmore Jungle. Ondore wants Reddas to infiltrate the empire and steal back the nethicite, while we go after Cid for his piece. A shame, I thought Reddas might join my team as a guest, he seems cool. The port town is pretty big and has a bar, so I will probably spend a bit of time here and see if any more hunts are available.


I get no instinct on how close I am to the end, such is the flatness of the plot. I guess war is brewing but it's been doing that for hours!


Current playtime: 41 hours

Highest level: 47 (Vaan)

Link to comment
Share on other sites

On 18/03/2022 at 00:56, Sprite Machine said:

I often feel like I'm not so much 'playing' FFXII as I am 'vaguely directing some characters around as they play the game for me'. Point them towards a group of enemies, turn the speed up, watch them win. Move on, repeat, level up occasionally. Satisfying in a way, but oddly detached.


It can be pretty chill :D and the "detachment" depends on how well-organised your gambits are. For me it's like tweaking the parts of a well-oiled machine - let it run in a few battles and look for holes in the setup - but better players than me can survive on autopilot for longer.

Link to comment
Share on other sites

Outside the pirate town of Balfonheim is Cerobi Steppe, a wide open hilly highland strewn with old windmills and full of reasonably tough monsters. As I didn't find a map seller in town, and didn't arrive there by my own means, I decide to explore the area and see which exits lead to where, racking up loot as I go.


Vyraal, a Rank V mark in the northern section, wipes me out, even with the direct assistance of the veira who posted the bill! That's one tough (and massive) wyrm. Like some of the other marks I've hunted, this one goes nuts when he's almost dead. Honestly, his life bar looks empty, I unleash a full suite of Mist attacks at him (with both sets of characters), inflict him with Slow and all of mine with Haste, and he's still standing at the end of it, walloping me senseless faster than I can heal. I don't get it.


Leaving this hunt aside for a while, I go west and rejoin the Tchita Uplands, so now I have my bearings. If I'm going to do any more hunting, I'll need to stick to Rank IV or below for now. To that end, I head to the Henne Mines to find the Mindflayer, who is harder to find than he is to defeat. My next mark is the Braegh (Rank IV), a big sparkly horse in Salikawood, who also goes down without much difficulty, although he's in a part of the wood that I hadn't explored before and I have to fight a King Bomb boss first to reach him.


A giant tortoise called Darksteel is in Sochen Cave Palace, and this is another straightforward battle. All other marks are Rank V or higher so I forget about them and continue the story, going to the Feywood through Golmore Jungle.


The Feywood is full of large old trees with big roots, and everything is covered in Mist. It swirls around the trees and creates spooky reflections and shadows. I encounter a boss, a large plant creature called Rafflesia. This fight almost ends in a loss, as it saps all my MP so I can't cast any spells, and I only beat it with a sliver of life left.


Beyond this area is a snowfield where I find a very useful accessory, the Bubble Belt, which grants double HP when equipped. (Whether it's capped to 9999 or not, I don't know, but I'm not far off finding out. - EDIT: it is) The snowfield is one of those annoying looped levels where the south exit takes you back to the north entrance and I can't see a way through. Perhaps the Mist is blocking me?


Everything is connected to everywhere, as back the other way leads to Paramina Rift, and a third way leads to a previously unexplored part of Henne Mines, although after nearly being killed by a couple of alarmingly strong bats, I get out of there again quickly.


Back to the infinite snowfield, I find a way to break through the loop. There are several structures with arched gates dotted around. Standing on each one reveals an illusion through the one of the gates, and following each one to the next structure opens the way through the south exit. The next field is almost the same, but there's a sealed magical door at the end, with an inscription that mentions needing a 'Gigas'. It's only because I remember that my esper, Belias, is a Gigas that I think to summon him. Lo and behold, with Belias active, the door opens and I enter the ancient city of Giruvegan. (I wonder if they do any nice avocado toast.)


The 'city' is just some ruins on a lake. There's still Mist everywhere. Ashe sees the ghost of Rasler again and follows him. There's a waystone that can teleport us deeper into the city but it's guarded by Daedalus, a headless armoured warrior with a sword. An easy fight, this one, and he turns back into a statue once beaten.


The waystone teleports us somewhere, possibly underground, into a strange quasi-futuristic environment, where ancient devices control magical forcefields and light bridges. I don't know how close to the end of the game I am, but I'm fighting Behemoths now, and they're usually a late game Final Fantasy enemy. I'm also fighting a variant of malboros called vivians, which deliver that delightful bad breath malboros are famous for. Most ailments can be cured with Esuna or Dispel, but a few like Oil and Disease require specific items and I don't have many to spare (nor the gambit slots to automate them). I could do with some ribbons, that's for sure!

Link to comment
Share on other sites

I remember being stuck on that gate where “gigas” was mentioned as I didn’t know what the word was connected to due to having not played it for a while and forgetting the reference. I’d not even thought to summon as I hardly ever used them anyway, certainly not outside of fighting any boss characters. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.