Jump to content
IGNORED

Turn your Wii into a fantastic emulation machine


dumpster
 Share

Recommended Posts

Maybe see if you can update the home brew channel.
 

I doubt it’s a card issue.

 

Probably something funny going on with the ios thingys and the home brew channel. Maybe installing priiloader nerfed something. you could always try uninstalling priiloader and we if that fixes it. 

Link to comment
Share on other sites

19 minutes ago, Ninja Doctor said:

Probably something funny going on with the ios thingys and the home brew channel. Maybe installing priiloader nerfed something. you could always try uninstalling priiloader and we if that fixes it. 

 

I expect you are right... Not sure how to get back to the default state now... Can't even seem to run through the process again as the Wii won't read the SD card to install the bomb thingy... :huh: Fun and games.... :D 

Link to comment
Share on other sites

10 minutes ago, Ninja Doctor said:

Open the home brew channel and see if it will connect online and update

Have that it connects to the network. No options to update though in any of the menus.... Think it's foobarred.

 

Not sure how I can actually reinstall homebrew again. The hack doesn't seem to work. I cannot update the system software to wipe over my changes and couldn't back up the NAND before I put priloader on.

 

Not a huge problem as it still works as a regular Wii console so it is functional. Just all the mods that are not working well except priloader :)

Link to comment
Share on other sites

OK so I deleted the homebrew channel and data.

 

Tried the letterbomb trick and it doesn't work. However the priloader is seeing the SD card and o can install things from there however not sure how I get the HomeBrew stuff to install from Priloader! Wow this is complex. Think I will just leave it :) This is a time sink.... Just wanted to have my games on a memory stick rather than on disks! 

 

Going to have to leave it for the time being just want to play some games.... :D

 

 

Link to comment
Share on other sites

I'd downgrade the security on your router to WPA, or no security at all (just for 5 minutes) then connect the Wii to the wifi, and follow the prompts to do a official install of the latest firmware. then start again using the guide.  I've modded many Wii consoles for friends and never had a problem.  Also check the Wiibrew links in the OP, there's a page of compatible SD cards, maybe worth a check to see if that's the problem (although I see you have tried a few).

 

I formatted my SD card in Windows 10 and had no problems but I think it might have been Fat32 before, so maybe use the SD Formatted utility mentioned earlier to be sure.

Link to comment
Share on other sites

7 hours ago, dumpster said:

I'd downgrade the security on your router to WPA, or no security at all (just for 5 minutes) then connect the Wii to the wifi, and follow the prompts to do a official install of the latest firmware. then start again using the guide.  I've modded many Wii consoles for friends and never had a problem.  Also check the Wiibrew links in the OP, there's a page of compatible SD cards, maybe worth a check to see if that's the problem (although I see you have tried a few).

 

I formatted my SD card in Windows 10 and had no problems but I think it might have been Fat32 before, so maybe use the SD Formatted utility mentioned earlier to be sure.

I've tried that too! Issue I have is that it already is at the latest version of the firmware :-/ so it doesn't update it :D The only time I want the latest firmware and it decides not to update it LOL. 

 

As for SD cards I think that they are fine. It was all working OK until I put the MMM package on. Or formatted a SD Card on Windows 10 (not that that should cause an issue really). I even tried a USB stick same issue. HBC detected the devices but won't show any of the apps. It must have glitched somehow.

 

Wonder if I can download the firmware refresh from somewhere they used to do this on the PS3 I think but not sure if Nintendo did this....

 

Edit OK had a look around it seems like a WAD file for v4.3E of the firmware is what I need. Nintendo did updates through the console via the internet and also via the game disks themselves. So either need to figure out how to get this WAD firmware patch file from one of my game disks or hunt around the internet.... 

Link to comment
Share on other sites

@MattyPI can't test this at the moment because I'm out, but this link from the OP I think will let you replace your OS with an old version from Nintendo servers, which will then allow you you to use the official update method to go to the latest version. Then you can start  then to start with the mod process. http://wiibrew.org/wiki/NUS_Downloader

 

I'll have a proper look later when I get home.

Link to comment
Share on other sites

1 hour ago, dumpster said:

@MattyPI can't test this at the moment because I'm out, but this link from the OP I think will let you replace your OS with an old version from Nintendo servers, which will then allow you you to use the official update method to go to the latest version. Then you can start  then to start with the mod process. http://wiibrew.org/wiki/NUS_Downloader

 

I'll have a proper look later when I get home.

@dumpster Much appreciated! Would be great to get this sorted! :)

 

 

Link to comment
Share on other sites

Decided to pick up another Wii and have a go with that one and stop messing with my current one! Don't want to brick it besides will be nice to have a vanilla one and a modded one! Also later on for spares too. Managed the pick one up with three games etc for £40 they are so cheap these days. Price of a PS4 game :D

 

edir This one also has been modified and has Priloader on it! I was hoping that it would be a clean machine. At least I can tinker around with this one and reset the firmware etc! Now to figure out how to install WAD files without the homebrew channel. This is turning into quite the project :)

Link to comment
Share on other sites

And...still nothing showing in the Homebrew channel. 

 

Has to be something to do with the format of the SD Cards.... Jeez. My windows build is this:-

 

image.png.a16c109c4f1fe2b56cc942c595117135.png

 

Wonder if its something in Windows that is causing this.... 

 

Link to comment
Share on other sites

Used this formatter.

 

The odd thing is that one of my cards has worked in the past!!! I installed MMM with it and Priloader.... Really strange. Think when I formatted it in Windows 10 it did something to it.... tried various formatting tools (including the one you have linked too!). Nothing has worked!

 

Completely weird... The only other thing is that my memory stick adapter thing I'm plugging into the PC is faulty somehow (doubt it but never rule anything out!).

 

I have a USB memory stick (16GB) can you create a apps folder on that and will HBC pick it up... noticed it has USB options in the menu....

 

EDIT: Well just formatted the card on a Windows 8 machine -  also tried a USB stick.  Neither worked. This is getting kind of infuriating now. But must solve this problem :D

Link to comment
Share on other sites

1 hour ago, dumpster said:

Got to be the SD card. Get down cex and spend a tenner on 5 random 2gb cards. They have a 48 hour money back policy!

 Sadly don't think this will solve it. I've got 5 SD cards here all of various sizes (including a 2GB one!) and one did work however now doesn't. Which Is why I think its a formatting issue on WIndows. Just not sure what it could be.

 

 

Link to comment
Share on other sites

6 minutes ago, MattyP said:

 Sadly don't think this will solve it. I've got 5 SD cards here all of various sizes (including a 2GB one!) and one did work however now doesn't. Which Is why I think its a formatting issue on WIndows. Just not sure what it could be.

 

 

Try that SD formatter from the link earlier and let us know how you get on. 

Link to comment
Share on other sites

JUST GOT IT WORKING!!!!

 

OK so redownloaded all the mods again into a different folder on my PC. Copied them over again and hey presto it worked. Still not sure what the issue was. Probably corrupt downloads perhaps or bad blocks on the drive I was copying them too who knows. But it works! Thank you all for the hints with this also thanks to @dumpster for posting the original topic! 

Link to comment
Share on other sites

Might be worth adding a few things to the original topic first post....

 

You can also use this technique if letterbomb doesn't work or you don't have an SD card to hand.

 

https://wii.guide/str2hax.html

 

You need to change your DNS settings and have a network connection. Just follow the instructions and DO NOT click any buttons on the screen when the blue background with a pony shows up. Just leave it for a couple of minutes to download and start patching the exploit in. Works a treat.

 

The other thing I found is that SDHC cards work fine for the LetterBomb hack. Just make sure they are formatted to FAT32 (as all storage devices need to be when connecting to the Wii).

 

This is awesome BTW just popped a 64GB USB stick in the back of the Wii and installed my favourite Wii games onto it. Easy to go bonkers and put lots of titles but then you end up with paralysis of choice so wanted to minimise that and curate a collection of games. Great to have everything on solid state and not rely on the aging drive inside of my Wii. Now also sorted out my original Wii so have two modded Wiis! Great to have a spare I guess! :) Will have one hooked up to the man den and one in the lounge for Wii Fit / Wii sports etc ie games that take more space.

 

Link to comment
Share on other sites

  • 4 months later...

I've just found my old Japanese Wii in the loft. No PSU or controllers and the FLAP is broken but thought it might be of use to someone for modding? PM me if you want it for the cost of delivery.

 

I'll put it in the for free topic if noone claims it.

 

 

Link to comment
Share on other sites

  • 1 month later...

Thanks for this! I am getting stuck at the custom os. I do all the things and it says failed (red box). Is there a common way this could go wrong? What could I be missing? I have done all the previous steps with success. I did try installing a wad with the mmm first, but then I realized I needed the custom os for that. And I'm not sure that bootmii installed correctly, I may have removed the SD card too soon, is that required? If so can I just start from the beginning to reinstall? The homebrew channel works fine and I can run roms off an emulator. Thanks. 

Link to comment
Share on other sites

4 hours ago, Andi said:

Thanks for this! I am getting stuck at the custom os. I do all the things and it says failed (red box). Is there a common way this could go wrong? What could I be missing? I have done all the previous steps with success. I did try installing a wad with the mmm first, but then I realized I needed the custom os for that. And I'm not sure that bootmii installed correctly, I may have removed the SD card too soon, is that required? If so can I just start from the beginning to reinstall? The homebrew channel works fine and I can run roms off an emulator. Thanks. 

Yes, I say in the OP to do every step in order and don't miss any.  If you have any reason to doubt that BootMii installed go back and do it again.  You don't need to remove the SD Card.

Link to comment
Share on other sites

  • 2 weeks later...
34 minutes ago, Super Stop and Shop said:

Anyone have recommendations on the best way to play Japanese GC games on a US Wii? How the fuck do I blow up this region lock bullshit?

Follow instructions in OP to hack a Wii and Step 8 shows how to install Priiloader, which can enable backward compatibility on boot (amongst other system stuff) (so im told, havent tested it dont think lol)

 

Should take less than an hour to hack wii (use a <2gb card) but maybe goodbye save game?!

Link to comment
Share on other sites

On 27/02/2021 at 19:15, Super Stop and Shop said:

Thanks, guys. I'll give this a go at some point in the near future. 

 

 

Honestly it takes me less than 15 minutes from fresh Wii to fully hacked.

 

If you follow OP and hopefully none of the links are dead, it's very straight forward to do. Heres the TL:DR version:

1. Copy files to SD card

2. Put SD card in Wii

3. Run the message board. DONE. That's it hacked on  basic level -  It installed a 'Homebrew Channel' which shows all the Apps in the App Folder on the SD card (you can add apps this way). From then on you just add apps you want like stuff for region-unlocking etc and run em. You can also install Channels (like Photo Channel etc) which are basically shortcuts to a specific App (whatever you want).

 

Very simplz.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.