Jump to content
IGNORED

Turn your PlayStation Classic into a fantastic emulation machine


Tomdominer
 Share

Recommended Posts

On 11/08/2019 at 21:59, beakbeak said:

I was wondering if someone could check something out for me:

 

R-type delta constantly crashes in Bleemsync. I’ve tried a few ROMs. It happens the most when I choose the tentacle option and I’ve beaten level 1 and level 2 is about to start.

 

bit gutted as R-type delta is one of my favourite ps1 games 

 

Oh and one more thing; sometimes when games crash in bleemsync, there's a way around it. 

 

 

I haven't looked for a solution to the R-Type delta problems, but when I found FF VIII crashing in a certain location every time, I found out it was indeed a common problem and they fixed it/found a solution by going into the bleemsync menu, and changing (in this case) one of the parameters.

 

Maybe if you look around on the internet, R-Type delta crashes can be fixed in a similar way.

Link to comment
Share on other sites

On 11/08/2019 at 21:59, beakbeak said:

I was wondering if someone could check something out for me:

 

R-type delta constantly crashes in Bleemsync. I’ve tried a few ROMs. It happens the most when I choose the tentacle option and I’ve beaten level 1 and level 2 is about to start.

 

bit gutted as R-type delta is one of my favourite ps1 games 

 

What seems to fix it (and most bleemsync crashes), is simply turning off the texture filter in the bleemsync menu. Game looks a bit worse though. Quite a bit actually...  :unsure:

 

Scratch that. Works for some games, but alas not R-Type delta   :(

Link to comment
Share on other sites

On 11/08/2019 at 21:59, beakbeak said:

I was wondering if someone could check something out for me:

 

R-type delta constantly crashes in Bleemsync. I’ve tried a few ROMs. It happens the most when I choose the tentacle option and I’ve beaten level 1 and level 2 is about to start.

 

bit gutted as R-type delta is one of my favourite ps1 games 

 

Alright; this might solve your problem, if you're still fussed about it.

Anyhoo, it solves (most?) crashes in other games as well (most notably FF VIII, FF IX, Front Mission 3).

 

 

>>  Just go into the bleemsync menu; go to [BIOS/ Plugins]; change GPU plugin from "gpu_peops.so" to "builtin_gpu".

 

 

Apparently bleemsync uses  "gpu_peops.so" by default, causing lots of game to crash when the going gets tough (In FF VIII, I simply couldn't get past the Seifer boss fight on disc 3 at all). Changing it back to the default built-in GPU fixes that.

Link to comment
Share on other sites

11 hours ago, Keyboard Koala said:

 

Alright; this might solve your problem, if you're still fussed about it.

Anyhoo, it solves (most?) crashes in other games as well (most notably FF VIII, FF IX, Front Mission 3).

 

 

>>  Just go into the bleemsync menu; go to [BIOS/ Plugins]; change GPU plugin from "gpu_peops.so" to "builtin_gpu".

 

 

Apparently bleemsync uses  "gpu_peops.so" by default, causing lots of game to crash when the going gets tough (In FF VIII, I simply couldn't get past the Seifer boss fight on disc 3 at all). Changing it back to the default built-in GPU fixes that.

 

What an absolute legend! I’ll give this a shit! Thanks buddy

Link to comment
Share on other sites

In the end, I'm not really sure whether this'll work though, as most people tell me bleemsync runs on the builtin_gpu by default. No idea why mine runs on gpu_peops.so by default though. I'm sure I never changed anything but the scanlines. And it did cause a massive lot of crashes in my games. Still worth checking out to see how the settings are.

Link to comment
Share on other sites

16 hours ago, beakbeak said:

 

What an absolute legend! I’ll give this a shit! Thanks buddy

 

Ah, looks like changing the gpu in the menu doesn't work; BUT I somehow managed not to make it crash anymore at that given moment in the game (ie. tentacle type ship; start of mission 2). :D :D

 

Since it doesn't crash anymore I cannot really verify how I fixed it, but here's what I did: just created a save state before the final boss of mission 1. I did this to find out why it kept crashing. That's how I somehow stopped it from crashing. Sorry if this seems vague, but that's what I did, and now it doesn't crash anymore. I will look further into this, as it truly is an ace game, and I want to be sure this is running without crashes on my PS classic. 

 

 

 

EDIT: I can now confirm that this is indeed how I "fixed" this problem, as the game crashes again in level 2 right after entering the water. I did the same thing (ie. create a save state prior to the game crashing scene) and played through it without a hitch. I hope there is another less bothersome way around it, but for the time being I suppose you can get around it with this solution.

Link to comment
Share on other sites

  • 4 weeks later...

Looking for some game recommendations to try out as there are so many titles I've never heard of as I mainly play Neo Drift Out all of the time! Speaking of which I just discovered this:

Great 1000 Miles Rally: Evolution Model
https://www.youtube.com/watch?v=FEzjpPDMp0E

And its a great game in a similar style. Emulates quite well on the PSC but there seems to be some mild graphical glitching but aside from that its perfectly playable. What gets your most play?

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

For those wondering:

 

 

Look how much better it all is.

 

The old version is absolutely rock solid and I've read a few complaints about the newer one so haven't upgraded but stuff like this makes it tempting, especially the Dreamcast improvements. PSC just keeps on delivering.

 

Link to comment
Share on other sites

  • 2 months later...

Hey all, so with the current lockdown, I've decided to busy myself with setting my Playstation Classic up to run my retro collection. I've gone with autoBleem 0.8.5 and I've got everything mostly set up. PS1 games are running fine and I've got a good range of retro machines working just fine through the Retro Arch app. I'm having two last problems which I'm breaking my head trying to fix:

 

1: The damn thing will not create a Mega Drive or SNES play lists. It goes through the motions of scanning all the ROMS and then... nothing. All my ROMS are zipped but run fine on my various alternative retro machines (Android stand alone emulation apps and OpenEmu on Mac). I have gone as far as to manually create a Mega Drive play list with a few games in and sure enough, that is recognised and the games run fine. I'm not exactly relishing the prospect of manually adding every single MD and SNES ROM in my collection, so if anybody has any better suggestions or ideas on what I'm doing wrong, that would be appreciated.

2: Mega CD and Saturn games will not run. I've tried both pre-installed cores for both systems, the Bios files are okay (at least there's nothing in the log file about missing or problem Bios files, and they're the same Bios files which OpenEmu uses without problem). The ROMS are all in .bin / .cue format, which I've read should be okay, but on launching the ROMS, Retro Arch flips to the black screen, then immediately jumps back to the main menu with an error message, "unable to load content" I think. It's a generic error message though.

 

If anyone can offer any assistance or advice in what to try next, I'd be most grateful. :)

 

As a more general comment, I'm loving the set up as a whole. Linking the rewind hot key input to the L2 button and then being able to rewind the action has made some of these games a joy to complete again. If I can just get these last two issues resolved, I'd have my retro needs sorted. Thanks in advance for any help offered. :)

Link to comment
Share on other sites

4 minutes ago, AceGrace said:

I have got those dodgy drug named USB sticks from Amazon with hundreds of games on them.

 

Haven't tried them yet though :unsure:


the ones that root your psone do you can’t install anything else on them? Or did they take that out yet?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.