Jump to content

MiSTer: FPGA gaming


Dr_Dave
 Share

Recommended Posts

47 minutes ago, Rob G said:

Morning!

 

I'm about to join the MiSTer party with one on the way from eBay. 

 

https://www.ebay.co.uk/itm/334089305737

 

I just have a couple of questions for you guys if you can help please?

  1. What's the 'best' way to get RGB SCART output?  VGA to SCART or HDMI to VGA to SCART? https://www.retrorgb.com/mister-240p-over-hdmi.html
  2. Do I need one of these with the setup I've bought? https://misterfpga.co.uk/product/mister-usb-bridge-board/
  3. Can the MiSTer take a 512 GB Micro SD card?  

I picked up a Sony CRT last night which will be the main screen for this to be used on.  I'll post some pictures once it is all setup.

 

Cheers

Regarding the RGB output, this works perfectly: https://coolnovelties.co.uk/coolnovelties/sinclair-zx-spectrum/312-zx-spectrum-next-analog-rgb-scart-cable-0705693507088.html

 

I’ll let someone else answer the other questions as I didn’t build mine.

Link to comment
Share on other sites

Welcome to the club, @Rob G As you've ordered the version with an i/o board it's probably best to go with the vga to scart lead. Someone earlier a page or two back linked a few of the cables that work with MiSTer.

I'd be very suprised if the package you bought didn't have that USB bridge to connect the USB hub to the DC-10, I wouldn't worry about that at this stage. Also, no problems with using a 512GB card. Also worth mentioning that you can also use external hard drives as well.

Here's one of the RGB cables that Swainy linked to a few posts back.

 

Link to comment
Share on other sites

On 26/07/2021 at 07:49, shiffy said:

New arcade games alert, The Jackal and Iron Horse have been released to the public by Ace. I'm happy to have played a tiny part in bringing Iron Horse core to the MiSTer project, but all credit really should go to Ace & ElectronAsh. I hope you enjoy these releases!

https://github.com/MiSTer-devel/Arcade-IronHorse_MiSTer#readme

 

Run your updaters!

 

Does this mean we might see Track & Field finally coming to the MiSTer soon?!

Link to comment
Share on other sites

There's no doubt in my mind that we will see Track & Field / Hyper Olympic at some point, it's more "when" rather than "if". However, at this moment in time I'm not aware of anybody actively working on it. I doubt we'll be seeing it anytime soon. From a hardware perspective Track & Field has more in common with Gyruss than either The Jackal or Iron Horse.

 

Also, I don't think anything has really changed with the status of the Japanese dev MiSTer-X in terms of his situation. He's made the odd contribution on github this year, but doesn't appear to be actively working on anything MiSTer related at the moment. Given his health problems everyone is being extremely respectful to him & giving him the space he needs, I don't think anybody really knows what his current situation is. MiSter-X does have a Track & Field core that he made for his own private use for another board, he's expressed his desire to bring to MiSTer some time ago but that was before all of his health issues had arisen.

Link to comment
Share on other sites

On 26/07/2021 at 20:45, shiffy said:

That's strange, @Swainy All I can suggest for the moment is to try running update_all again and see what happens. If that doesn't work, let me me know & we'll delve in deeper to see what the problem is. From the behavior you've described it sounds like you haven't got the roms.

Well I deleted the Mame roms (which were there) and the mra files for those two games, ran the update all script which re-installed them and I’ve still got the same issue. Very strange.

Link to comment
Share on other sites

6 minutes ago, Klatrymadon said:

Yeah, I'm having the same problem as Swainy with Jackal and Iron Horse. I don't know where Update_All pulls its roms from, but sourcing our own might be worth a try...

I’ve now fixed the problem. The RBF files were missing! 
 

They should be in the _arcade/cores folder. 
 

Download them from https://github.com/MiSTer-devel/Arcade-Jackal_MiSTer

 

and 

 

https://github.com/MiSTer-devel/Arcade-IronHorse_MiSTer

Link to comment
Share on other sites

Very strange that the rbf files didn't come down @Swainy. Would you mind sharing your update_all settings, I'll take a look and see if anything leaps out at me there.

 

In theory, the standard official script should have downloaded the rbf files automatically as they were on MiSTer_devel. In your Scripts folder you should see something called "update.ini". Could you post post (or pm me) a copy of that? Have you made any alterations to "update.sh"?

Link to comment
Share on other sites

4 minutes ago, shiffy said:

Very strange that the rbf files didn't come down @Swainy. Would you mind sharing your update_all settings, I'll take a look and see if anything leaps out at me there.

 

In theory, the standard official script should have downloaded the rbf files automatically as they were on MiSTer_devel. In your Scripts folder you should see something called "update.ini". Could you post post (or pm me) a copy of that? Have you made any alterations to "update.sh"?

Will do, I won’t get a chance until tomorrow evening now though.

Link to comment
Share on other sites

I hooked up the Mister to my PC monitor to see if the Cave cores would sync there, and they seemed to start up perfectly well, though the roms aren't working since my last update (previously I could see DoDonPachi and Esprade zipping by in desynchronised form). After changing the refresh rate to 60hz in the cores' options, though, I found they were still were still desynchronised / scrolling wildly on the CRT. Does this suggest it was never a refresh rate issue at all? Is there anything else I could try? (I hope it's not one of those "throw your RAM module out and buy another" issues I keep hearing about...)

 

Thanks!

 

Edit: since hooking it up to both the HDTV and the CRT I'm now getting no sound when playing on the CRT. This is after being switched off for an hour, having all wires secured, etc. :(

Link to comment
Share on other sites

I'm in on this when the Saturn core is ready – the progress is very promising, so it might not be as far off as I've been expecting.

I've a question – do you guys run these through something like an OSSC or Retrotink, or is the video output already suitable for modern TV's? 

I'm expecting the cost to be more or less the same as a Saturn + ODE + upscaler, with the benefit of running all the other consoles. The need for an upscaler might tip it over though.

Link to comment
Share on other sites

13 hours ago, Klatrymadon said:

Edit: since hooking it up to both the HDTV and the CRT I'm now getting no sound when playing on the CRT. This is after being switched off for an hour, having all wires secured, etc. :(

 

No sound via HDMI either! Hope I haven't blown something on the I/O and DE-10 boards by messing around with DDP's refresh rate, or by plugging in both analogue and digital display cables...

Link to comment
Share on other sites

14 hours ago, Klatrymadon said:

 

Edit: since hooking it up to both the HDTV and the CRT I'm now getting no sound when playing on the CRT. This is after being switched off for an hour, having all wires secured, etc. :(

 

I hope you didn't do what I did last night which was to hook up a keyboard and accidentally press the mute button? It took me over an hour to work out what was going on!

Link to comment
Share on other sites

Thanks, both! Hmm, I didn't hook up a keyboard (since I have the OSD/menu set to the 'PS' button on my stick, I don't really need one most of the time), but is it possible I've muted it some other way? I'll have to look into this!

Link to comment
Share on other sites

Absolute madness.

 

 

19 hours ago, pastry said:

I'm in on this when the Saturn core is ready – the progress is very promising, so it might not be as far off as I've been expecting.

 

 

Better get ur credit card ready!

 

  

19 hours ago, pastry said:

I'm expecting the cost to be more or less the same as a Saturn + ODE + upscaler, with the benefit of running all the other consoles. The need for an upscaler might tip it over though.

 

actually, you dont need the upscaler. You can output to a CRT and to 1080p HDMI simultaneously.

Link to comment
Share on other sites

On 28/07/2021 at 20:15, Klatrymadon said:

Yeah, I'm having the same problem as Swainy with Jackal and Iron Horse. I don't know where Update_All pulls its roms from, but sourcing our own might be worth a try...

Klatrymadon, could send you me a copy of your "update.ini" file? I've just had a look at Swainy's file, fairly certain I've identified the problematic setting, but I want to see if your file looks the same. I've told Swainy what to change, but I won't post it publically until @Swainy has confirmed to me it works (I don't have a spare SD card for testing at the moment - and piano practice is tonight's main focus!)

Link to comment
Share on other sites

On 28/07/2021 at 20:15, Klatrymadon said:

Yeah, I'm having the same problem as Swainy with Jackal and Iron Horse. I don't know where Update_All pulls its roms from, but sourcing our own might be worth a try...

I think I’ve found the problem, LLAPI needs to be set to true. At least, that worked for me.

Link to comment
Share on other sites

On 27/07/2021 at 10:42, Swainy said:

Regarding the RGB output, this works perfectly: https://coolnovelties.co.uk/coolnovelties/sinclair-zx-spectrum/312-zx-spectrum-next-analog-rgb-scart-cable-0705693507088.html

 

I’ll let someone else answer the other questions as I didn’t build mine.


I wanted to confirm that the cable arrived and, along with updating 2 settings in the config file (thanks for the link @Klatrymadon), it works like a charm! 
 

I have only tinkered with it thus far, but I’m a big fan of what I’m seeing. 

Link to comment
Share on other sites

12 hours ago, Swainy said:

I think I’ve found the problem, LLAPI needs to be set to true. At least, that worked for me.

Actually, I didn’t realise that LLAPI is for use on Bliss Box boards so don’t set that to true.

Link to comment
Share on other sites

I bit the bullet and ordered the DE10 earlier today so would really appreciate it if someone could just check confirm the following shopping list will be broadly all I need;

 

1) Digital I/O Board (will be using HDMI to start, and even if I connect to a CRT it won't be connected to both at the same time)

2) 128Mb RAM Module

3) USB Hub (the stackable one)

4) Bluetooth adapter (i'll be using a Wii U Pro pad to start)

5) Wifi adapter

6) SD Card

 

Is an upgraded power supply necessary? Does the I/O board negate the need for a keyboard?

Link to comment
Share on other sites

I'm using one of these usb leads for power .. StarTech.com 1m USB to Type N Barrel 5V DC Power Cable - USB A to 5.5mm DC - 1 Meter USB to 5.5mm DC Plug (USB2TYPEN1M), Black https://www.amazon.co.uk/dp/B009JXJITS/ref=cm_sw_r_apan_glt_fabc_ES1J2424H2Q375V3DC65 seems to work well enough for now.

Also I'm just plugging HDMI directly into the DE10, am waiting for an analogue IO board for my CRT

Link to comment
Share on other sites

46 minutes ago, Colonel Panic said:

Are you getting the digital I/O board just for some buttons? 

 

Nope, but I think i've got a bit mixed up somewhere. Can I output RGB Scart without the I/O board?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.