Jump to content
IGNORED

MiSTer: FPGA gaming


Dr_Dave
 Share

Recommended Posts

Is it possible to pair a DualShock 3 with MiSTer over Bluetooth for the PSX core? Not expecting the lag to be ideal but I use mine as a wireless PS2 pad with a Brook adapter and it works quite nicely.

Link to comment
Share on other sites

43 minutes ago, Tomdominer said:

Hhhmm, oh dear.

 

Maybe I need to switch the mode or something? What mode do you have the controller in? (Don't worry if you don't know)

 

X-Input.

Link to comment
Share on other sites

1 minute ago, Tomdominer said:

Tried that. It seems that it only works wired. Maybe its a USB dongle issue? I'm using the 8bitdo ps classic adapter.

 

What are you using?

 

Just a normal BT adaptor. I also have the 8bitdo adaptor (because for some reason, my BT adaptor can't connect two PRO2s at the same time) - it works with d-pad mode, but come to think of it, I've never tried it with the analogs. When I get a minute, I'll fire it up and try.

Link to comment
Share on other sites

MSU-1 is a nice feature ..... at least, I thought that at the time when I got my SD2SNES. I think the only games I truly appreciated having a CD audio quality on was Chrono Trigger, F-Zero & Zelda.

I've been trying to get my exisiting SNES MSU-1 game set working on the MiSTer for the last hour but haven't had any success yet. Have you managed to make any work yet, @Colonel Panic? The patched roms seem to work, but no MSU audio.

Link to comment
Share on other sites

17 hours ago, Dr_Dave said:

Just a normal BT adaptor. I also have the 8bitdo adaptor (because for some reason, my BT adaptor can't connect two PRO2s at the same time) - it works with d-pad mode, but come to think of it, I've never tried it with the analogs. When I get a minute, I'll fire it up and try.

 

So, using a standard bluetooth adapter, the analogue sticks started working. I suppose it must be the ps classic adapter. I wonder if I push the standard firmware onto it, it would work....

Link to comment
Share on other sites

41 minutes ago, Tomdominer said:

 

So, using a standard bluetooth adapter, the analogue sticks started working. I suppose it must be the ps classic adapter. I wonder if I push the standard firmware onto it, it would work....

 

I just tried a PRO2 with the 8bitdo adaptor rather than the BT adaptor, and both analog and vibration work through it. I do seem to remember now you mention it that I had to flash it with a firmware update to get it to work, but I can't remember which one.

Link to comment
Share on other sites

I tried flashing it with the standard 8bitdo adapter firmware, and the analogue sticks started to work, but then I started getting drops. I'll just use the BT adapter.

 

Thanks for checking though!

Link to comment
Share on other sites

On 01/05/2022 at 12:29, Fallows said:

I've ran into a really nice surprise today. We decided to test out the MiSTer on our new speakers for a bit, but then at the same time also learned that the Denon will handle vsync_adjust=2 and pass it to the otherwise non-compatible TV! Even the generally fussy cores such as the NeoGeo work perfectly.

 

The regular vertical and horizontal scanlines look great when doubled up, like some kind of massive LCD handheld.

 

IMG-1620.jpg

 

Just to follow up on this. I've tried the setting you recommended and they didn't look great for me.

 

I'm running a resolution of 2048x1536 @60hz (I also tried 720p, but that seemed to totally mess up the scale-line scaling).

 

MiSTer_FFight_Shadow_Mask_2.thumb.jpg.c66f720ee22009bc5c6a8e8b80f4acb7.jpg

 

MiSTer_FFight_Shadow_Mask.thumb.jpg.49442e17cd120af98737a3f95db4f042.jpg

 

I just find that with both horizontal and vertical scanlines active, the pixels are too accentuated, and its too dark overall. I don't really like most of the shadowmasks on offer, but I do like the "Sony PVM (Generic) (~1980)"

 

Here are my settings. Mileage may vary...

 

Horz. filter: No Interpolation.txt

Vert. filter: Scanlines - Brighter.txt

Scan filter: Same as Vert

Gamma correction: Contrast_Boost_1.txt

Shadow Mask: 1x - Sony PVM (Generic) (~1980)

 

EDIT: Typo on the image, sorry. Should be "Horizontal & Vertical Scanlines", like Fallows.

 

Link to comment
Share on other sites

Any ideas as to why my update_all script keeps getting stuck at this specific step in the 'MAME-GETTER' process?

 

https://imgur.com/a/U3rLYZc

 

I've tried letting it run for a couple of hours, so I don't think it's a matter of waiting for the download to finish, sadly.

 

Also, is there a way to turn off the resolution/kHz info that pops up in the top left whenever the screen mode/refresh rate changes? It's handy to have but I find with the PSX core I'm constantly tapping the OSD button to get rid of it. :P

 

Thanks!

Link to comment
Share on other sites

10 hours ago, Klatrymadon said:

Any ideas as to why my update_all script keeps getting stuck at this specific step in the 'MAME-GETTER' process?

 

https://imgur.com/a/U3rLYZc

 

I've tried letting it run for a couple of hours, so I don't think it's a matter of waiting for the download to finish, sadly.

 

Also, is there a way to turn off the resolution/kHz info that pops up in the top left whenever the screen mode/refresh rate changes? It's handy to have but I find with the PSX core I'm constantly tapping the OSD button to get rid of it. :P

 

Thanks!

 

Not sure about the first, but you can disable the display into popup by setting "video_info" to 0 in the MiSTer.ini file.

Link to comment
Share on other sites

I bought an 8bitdo wired Pro 2 to use with the Playstation core, which I've been really pleased with. However, I've just gone to use it and the MiSTer is no longer recognising it. It's all very odd - my other controllers (both wired and wireless) work fine, and my PC recognises the controller without issues. Has anyone got an ideas about how to resolve this? LEDs 1 and 2 are flashing, where as it's just the first that is solidly lit when it's connected. However, I can't find that anyone has a similar problem with the wired pad from a quick search, and it's just really odd that it was working but now isn't.

Link to comment
Share on other sites

5 minutes ago, Count Buffalos said:

I bought an 8bitdo wired Pro 2 to use with the Playstation core, which I've been really pleased with. However, I've just gone to use it and the MiSTer is no longer recognising it. It's all very odd - my other controllers (both wired and wireless) work fine, and my PC recognises the controller without issues. Has anyone got an ideas about how to resolve this? LEDs 1 and 2 are flashing, where as it's just the first that is solidly lit when it's connected. However, I can't find that anyone has a similar problem with the wired pad from a quick search, and it's just really odd that it was working but now isn't.

 

Do you have the mode select switch on the back on the right one? (the one you configured it with) I used mine on "X" for x-input, which I think gets you the most buttons and vibration.

Link to comment
Share on other sites

3 minutes ago, Count Buffalos said:

Ok, I'll have a search. It's perplexing, it was working earlier today.

 

The flashing lights make it sound like it's just not connecting - have you tried another USB port? Does the main MiSTer controller config see it? Any other cores?

Link to comment
Share on other sites

Yeah, it's definitely not connecting with any of the USB ports and the main 'define joystick options' on the homepage no longer sees it. My wired 8bitdo SNES pad works as usual, as does the wireless M30 that I have. The other odd thing is that it works ok with my PC.

Link to comment
Share on other sites

11 hours ago, Dr_Dave said:

 

Not sure about the first, but you can disable the display into popup by setting "video_info" to 0 in the MiSTer.ini file.

 

Nice one, thanks for that!

 

Another query: can the PSX core handle games with multiple .bin tracks? Wizardry - Dimguil, which has three, didn't work, but I have no way of testing the files another way at the moment...

Link to comment
Share on other sites

Dangun Feveron is now playable via the Cave core.

 

@KlatrymadonIn short, the PSX core can handle games with multiple files. I've just loaded up Wizardy Dimguil and it works fine. Admittedly, I have compressed my copy down to single .chd file which was originally 3 bins & a cue file. I can test it in it's original bin/cue format in a little while if you wish.

 

Link to comment
Share on other sites

I've just had one of the 8Bitdo M30 USB Pads and an 8Bitdo Wireless USB Adaptor 2 delivered. 

 

I've got them working fine but it seems like I need to re-pair them every time I turn the Mister on or do a Cold Reboot. Is that how it should work or have I done something wrong somewhere?

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.