Jump to content

Warhammer 40K: Darktide - Xbox/Steam


rafaqat
 Share

Recommended Posts

  • 4 weeks later...
1 hour ago, Captain Kelsten said:

Fucking lol at these system requirements :lol:

 

1598697E-EF6B-45D7-92F3-2D00F0D84AEC.thumb.jpeg.7d3bc38936456cd651fcec68936600f2.jpeg

 

Jeez laweez.

 

Nice to see they restrained themselves at the high end by merely requiring a 4080. Did they leave the minimum expected FPS off the w/RT High because they didn't have the balls to write it while asking for that level of Hardware?

Edit - Devs: "We believe that most players can accept a short temporary loss of frame-rate to be able to get the overall gameplay we offer." Which sounds suspiciously like 'expect unstable and inconsistent frame rates no matter what' to me.

Link to comment
Share on other sites

Downloading now. Exciting! I'll edit this post to keep you updated -

 

1927 - 20% - 41m33s remaining

1932 - 19% - 36m40s remaining

1942 - 47% - 27m29s remaining - just going to nip to the loo so the next update may be delayed, depending on complications.

2000 - 70% - 14m38s remaining

 

I think I'm done with this cutting edge satire now.

Link to comment
Share on other sites

Well I was having a lovely time playing the prologue until my screen went black and an acrid burning smell came from my PC. I let it cool for 10 mins and it seems to be fine, but I might hold off playing again for a day or two and see if any reports come through of it frying graphics cards…fair warning.

 

Edit - 2080 btw.

 

Edit edit - yes I know games ‘frying’ graphics cards isn’t a thing, it’s an overheating system, before someone dekay’s me. 

Link to comment
Share on other sites

1 hour ago, Nathan Wind said:

Well I was having a lovely time playing the prologue until my screen went black and an acrid burning smell came from my PC. I let it cool for 10 mins and it seems to be fine, but I might hold off playing again for a day or two and see if any reports come through of it frying graphics cards…fair warning.

 

Edit - 2080 btw.

 

Edit edit - yes I know games ‘frying’ graphics cards isn’t a thing, it’s an overheating system, before someone dekay’s me. 


This really does happen. Do me a favour and check all your PSU cables at both ends carefully. I’ve melted a modular PSU cable at the PSU end before now and it smelled acrid but nothing else. 

Link to comment
Share on other sites

Seemingly no permanent damage. Took the card apart and had a good look and everything looks fine, plugs both ends look good. I just gave it a quick run for 20 mins and the temps were good. I've dropped settings right down to medium, capped frame rate at 60 so will see how it goes. It spins the fans up and down like a yoyo but seems stable. I'll give it a longer run later. It's obviously terribly optimised - I'm hoping it was just that having the audacity to try RT on low sent the card into meltdown, so I won't be touching that again until we're several patches in.

 

My advice at the moment is play with caution and have monitoring software running, which you check regularly. Or wait for the inevitable day one patch on launch day.

 

Edit - just noticed the LED name plate on the card isn't lit, so I'm hoping that's all that got fried and explains the burning smell.

Link to comment
Share on other sites

Anyone playing on Steam? Currently getting 30-40fps on a 4090 at max settings with DLSS off and raytracing on high. :lol:

DLSS helps a bit (and it has support for DLSS3) but it's still miles off. The absolute best performance I can get out of it is 120fps with everything set to off/low, DLSS3 on performance mode and frame generation turned on. But then it looks like Quake 2. Interestingly you can use frame generation with DLSS upscaling switched off, which yields the same performance. My GPU utilisation is about 40% and my CPU is doing almost nothing. This is at 1600p incidentally.

 

I did see someone on Reddit say the new Nvidia driver halved their performance, but nothing to corroborate that. Let me know if you fancy a game @Nathan Wind, we can see whose PC catches fire first

Link to comment
Share on other sites

Have seen this crop up a few times in various places - I didn't get anything much from it but poeple are saying it improves things. From Steam discussions -

 

Quote

1. Open Nvidia CP
2. Go to 3D settings
3. Enable Image Scaling
4. Select sharpness desired (20-35% is usually good) and enable/disable notification
5. Apply
6. Select resolution (you will see stuff like 85%, 77%, etc beside the new Image Scaling resolutions added. 85% is the sweet spot, everything else gets bad looking fast).
7. Launch Darktide (or any DLSS game)
8. Select desired DLSS level
9. Enjoy!

This will stack IMAGE SCALING and DLSS. Image scaling is fully supported by Nvidia, this is not some crazy EDID hack or whatever so there's no risk of damage. 

 

Load times are laughable, it looks like ass at medium, which is ludicrous given the system requirements, and I've had a couple of server disconnections. But my word it's really, really good when you do get a decent game.  I'm playing on Steam, yeah, and always up for a bit of 'tide. I'm on and off today, but hopefully on for a decent sesh tomorrow so happy to squad up.

Link to comment
Share on other sites

I've actually refunded it because it was borderline unplayable at times and I was getting close to two hours. Even on the lowest of the low settings (Quake 2 mode) the framerate was still all over the place. I'll check out the final release on gamepass, but hooboy if they don't get some optimisation done for the release day build it's going to cause a few headlines. The fact my GPU was on about 30% utilisation most of the time tells me there might be an underlying driver or game issue hampering performance. If it runs OK on gamepass I'll rebuy it on Steam, because it'll be really annoying if it disappears from gamepass. Thanks to the zero crossplay (even between Steam and Gamepass PC) I haven't really got anyone to play it with, my usual crew is a weird mix of Xbox and PC gamepass people.

Link to comment
Share on other sites

After those initial problems, this is running really well for me now and I'm absolutely loving it. The quality of rando players has been pretty good too with very few runner offers and everyone mucking in on revives, support and objectives. Servers have been mostly solid. I really hope they can sort out the performance and stuff for launch because the underlying game is brilliant and deserves to succeed.

Link to comment
Share on other sites

1 hour ago, Moz said:

How are you getting it to run acceptably? What resolution? Everyone saying “it’s fine for me” is playing at 1080p with DLSS on 😀

Medium/high settings mix, 1440p, no RT, DLSS on balanced, framerate capped at 60 and it’s honestly been absolutely fine the past couple of days. Hitches when loading in and occasional lag notwithstanding. I’m not making any excuses for it, it’s undeniably badly optimised but I’ve hit on a set up that works well for me after those initial problems so I guess I must just be one of the lucky ones.

Link to comment
Share on other sites

1 hour ago, Nathan Wind said:

Medium/high settings mix, 1440p, no RT, DLSS on balanced, framerate capped at 60 and it’s honestly been absolutely fine the past couple of days. Hitches when loading in and occasional lag notwithstanding. I’m not making any excuses for it, it’s undeniably badly optimised but I’ve hit on a set up that works well for me after those initial problems so I guess I must just be one of the lucky ones.

 

Ah OK. I'm trying to do a fair bit more with it but the main issue is it's using about 30-40% of my CPU and GPU. I don't really mind making it look like potato Quake 2 mode but it still dips wildly all over the place even when doing that.

 

Starting to wonder if it's a driver issue or something to do with my system/settings. This guy has virtually the same setup as me and he's getting 120fps near constant at 4k with DLSS quality. I was getting 40fps! His GPU usage is constantly around 90% too. Mine was never above 35%. 

 

 

Frame generation was definitely on for me (turning it off tanked my framerate further) although I'm not a big fan of it as it introduces a weird mousefeel and input lag. Weirdly turning DLSS on/off and changing settings didn't seem to make any impact, so I'm wondering if my DLSS wasn't kicking in properly. I might have to rebuy it and have another fiddle.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Use of this website is subject to our Privacy Policy, Terms of Use, and Guidelines.